PIX525透明模式详细配置过程

经常在这里请教大家问题,得到了很多帮助. 在此表示衷心的感谢
刚刚在摸索中配置了一次PIX525防火墙为透明模式。特贴出来和大家分享!为了让和我一样菜的弟兄们能看懂.请各位大虾不要嘲笑啊!~

如何连接电脑我就不多说了 网上到处都是。但好像要注意一点,先吧超级终端打开再给防火墙加电,不然超级终端上什么都看不到。

下面就是正是配置了:

由于一般的PIX系列的防火墙出场时候预装的IOS是6.X的版本 而只有7.0以上才支持透明模式.所以第一步是升级IOS

准备工作:

找一台和防火墙在一个交换机机上的计算机安装ciscotftp软件.去www.skycn.com上面就有.很简单汉化版.然后去cisco网站上下载一个7.0的bin文件(我下载的是pix701.bin)放到tftp服务器的根目录下

正式开始:

防火墙通电,按ESC进入monitor> 状态下。

monitor> address 192.1.1.1   –设置防火墙IP
address 192.1.1.1
monitor> server 192.1.1.2    –设置tftp服务器的IP
server 192.1.1.2
monitor> ping 192.1.1.2      –检测一下是否能ping通
Sending 5, 100-byte 0x7970 ICMP Echoes to 10.32.2.78, timeout is 4 seconds:
!!!!!
Success rate is 100 percent (5/5)
monitor> file pix701.bin     –声明你下载的那个bin文件的全称
file pix704.bin
monitor> tftp                –开始灌入
tftp pix704.bin@192.168.1.80………………………

耐心等待.一直到出现非特权模式的那个”>”符号.下面要吧bin文件考到flash里面去,以后启动的时候才能正常使用

pixfirewall> en

Password:

pixfirewall# con t

pixfirewall(config)# interface ethernet1                                                –进入端口模式

pixfirewall(config-if)# ip address 192.1.11 255.255.255.0              –配置e1口的IP

pixfirewall(config-if)# nameif inside                                                     –配置e1口为防火墙的inside口

INFO: Security level for “inside” set to 100 by default.

pixfirewall(config-if)# no shutdown                                                     –激活inside口

pixfirewall(config-if)# ping 192.1.1.2                                            –测试一下

Sending 5, 100-byte ICMP Echos to 192.1.1.2, timeout is 2 seconds:  

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

pixfirewall(config-if)# exit                                                                   –退出端口模式

pixfirewall(config)# copy tftp flash:                                                      –copybin文件

Address or name of remote host []? 192.1.1.2                                –tftp服务器IP

Source filename []? pix701.bin                                                             –文件名

Destination filename [pix701.bin]? pix701.bin                                        –确认

Accessing tftp://192.1.1.2/pix701.bin…!!                                       –开始copy 耐心等待

Writing file flash:pix701.bin…!!!!!!!!!!!!!

5124096 bytes copied in 82.80 secs (62488 bytes/sec)

pixfirewall(config)# reload                                                                   –升级完成.重启!!!!!!!ps.第一次启动时间会稍长不要着急

下面才是配置.也很简单了,和刚才配置差不多配置outside口和inside口并激活,只是注意不要配置IP.这可是透明模式.谁见过一根网线两端还有IP的?

pixfirewall> en

Password:

pixfirewall# con t

pixfirewall(config)# interface ethernet0

pixfirewall(config-if)# nameif outside

INFO: Security level for “outside” set to 0 by default.

pixfirewall(config-if)# no shutdown

pixfirewall(config-if)# exit

pixfirewall(config)# interface ethernet1

pixfirewall(config-if)# nameif inside

INFO: Security level for “inside” set to 100 by default.

pixfirewall(config-if)# no shutdown

pixfirewall(config-if)# exit

铛铛铛~~~~~~~~这里可是最重要的了 其实就是5句话

pixfirewall(config)# firewall transparent                                              –设置防火墙为透明模式

pixfirewall(config)# access-list out-list extended permit icmp any any     –设置允许通过所有的协议

pixfirewall(config)# access-list out-list extended permit ip any any         –设置允许通过所有的IP

pixfirewall(config)# access-group out-list in interface outside                –把刚才的访问列表绑在outside口

pixfirewall(config)# access-group out-list out interface outside              –把刚才的访问列表绑在outside口

pixfirewall(config)# ip address 192.1.1.1 255.255.255.0                    –设置一个以后配置防火墙的IP

OK大功告成,怎么样够简单把.

发表回复

您的电子邮箱地址不会被公开。